Drill saves and historical exports not displaying some historical data.
Incident Report for Vena Solutions
Resolved
The Vena team is happy to report that the issue of drill saves and historical data not showing is now resolved. Thank you for your patience and trust in Vena while we worked to resolve the issue.
Posted Oct 25, 2023 - 02:08 UTC
Update
The Vena team would like to provide an update on the issue of drill saves and historical data not showing.

While we’ve made significant progress in processing the backlog of audit data, the volume of data has been larger than what we anticipated. As a result, we’ve had to adjust our recovery timeline.

We understand the importance of this data to your operations and sincerely apologize for any inconvenience this may have caused. Our team is working around the clock to expedite this process and ensure the accuracy and integrity of your data. We now anticipate that most customers will experience a full recovery by Thursday, October 25th. However, some customers may recover earlier then this date.

Thank you for your patience and understanding. We remain focused on supporting you and will update you on our progress.
Posted Oct 23, 2023 - 21:49 UTC
Monitoring
The Vena team has successfully identified the root cause of drill saves and historical data not showing the most recent audit history and a fix has been applied.

We've begun processing the backlog of audit information and are working diligently to get everything back on track.

We're committed to a swift recovery for our valued customers. We anticipate most customers will experience full recovery by Monday, October 23rd, however some customers may require until Tuesday to be fully caught up.

Thanks for your patience and trust in Vena!
Posted Oct 20, 2023 - 19:47 UTC
Update
We are continuing the investigate the root cause of the issue and will continue to post updates as we progress.
Posted Oct 18, 2023 - 19:36 UTC
Investigating
Please be advised that we are currently experiencing an issue with drill saves and historical exports not displaying some historical data. We are currently investigating the issue and will post updates as we progress.
Posted Oct 18, 2023 - 17:31 UTC
This incident affected: US1.