V365 Unavailable - CA4

Incident Report for Vena Solutions

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 22:42 UTC

Monitoring

The issue has been identified and a fix has been implemented.
Posted Apr 15, 2026 - 21:42 UTC

Investigating

We are actively investigating an issue impacting V365 that is preventing some files from being processed. Our support teams are engaged and working to resolve the problems, and we will provide updates as progress is made
Posted Apr 15, 2026 - 20:35 UTC
This incident affected: CA4.