V365 - Compatibility Error

Incident Report for Vena Solutions

Resolved

This incident has been resolved.
Posted May 30, 2025 - 17:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 30, 2025 - 16:52 UTC

Investigating

We are currently investigating an issue affecting V365, which is preventing files from being processed. Our support teams are engaged and we will keep you updated on our progress.
Posted May 30, 2025 - 14:25 UTC
This incident affected: US2.