ETL Jobs Queued

Incident Report for Vena Solutions

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 18:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2025 - 18:20 UTC

Identified

We have identified an issue with some ETL Jobs stuck in queued state, and are rolling out a fix shortly. Our support teams are engaged, and we will keep you updated on our progress.
Posted Nov 10, 2025 - 17:47 UTC
This incident affected: US1, US2, US3, US4, and CA3.