A permanent fix is being rolled out in phases over the next 5 business days to ensure stability across the Vena platform.
If you are still experiencing issues, your environment may not yet have received the update. If the issue persists after the rollout period or if you require immediate assistance, please have a designated representative from your organization contact the Vena Support team.
As a result of this resolution, the previously recommended workarounds are no longer necessary.
We sincerely apologize for the disruption and thank you for your patience as we worked to resolve the issue.
Posted May 15, 2025 - 00:15 UTC
Investigating
We are currently investigating reported issues affecting Vena 365 for Windows users running Excel Version 2504. Our support teams are actively engaged and working to identify the root cause. If you have not yet updated to Excel Version 2504, we advise holding off for now. If you're already impacted, consider switching your Office update channel from Current to Monthly Enterprise as a temporary workaround.
Posted May 08, 2025 - 18:35 UTC
This incident affected: US1, US2, US3, US4, US5, EU1, EU2, EU3, CA3, CA4, and SS.