V365 - unavailable

Incident Report for Vena Solutions

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 22:21 UTC

Monitoring

Microsoft has implemented a fix, and we’re seeing signs of recovery. Microsoft expects full resolution by 23:20 UTC today (Oct 29, 2025).

We’ll continue to monitor the situation closely and provide updates as progress is made.
Posted Oct 29, 2025 - 21:01 UTC

Identified

The issue impacting our Add-ins has been identified as related to a global incident affecting Microsoft services. We are actively monitoring the situation and awaiting further updates from Microsoft on their progress toward resolution.
https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 17:48 UTC

Investigating

Our cloud provider has reported an incident currently affecting the V365 feature. We are actively engaged with their team to mitigate the impact and restore full functionality at the earliest opportunity.
Posted Oct 29, 2025 - 17:15 UTC
This incident affected: US1, US2, US3, US4, US5, EU1, EU2, EU3, CA3, CA4, and SS.