EU1 Experiencing Degraded Performance

Incident Report for Vena Solutions

Resolved

Issue has been resolved
Posted Aug 12, 2026 - 17:12 UTC

Identified

The cause of this issue has been identified. Our teams are taking steps to restore full service.
Posted Aug 12, 2026 - 16:10 UTC

Investigating

We are currently investigating reports of degraded performance on EU1
Posted Aug 12, 2026 - 14:41 UTC
This incident affected: EU1.