Vena Copilot Degraded Performance - US1, US2 US3 and US5

Incident Report for Vena Solutions

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 19:27 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2025 - 18:55 UTC

Investigating

We are currently investigating an issue impacting the US Vena hubs affecting our Vena Copilot Service. Our support teams are engaged and we will keep you updated on our progress.
Posted Apr 14, 2025 - 17:43 UTC
This incident affected: US1, US2, US3, and US5.